Some video-messages not appearing
Incident Report for CareApp
Postmortem

An upstream issue in Flutter’s image picker plugin was incorrectly marking video files as images. This meant that our video encoding pipeline was not being run for these video files, and the videos were not visible in CareApp’s feed.

Our immediate fix was to patch the image picker plugin and release a new version of CareApp. We then manually triggered our video encoding pipeline for existing videos, resolving the issue.

Posted Apr 21, 2021 - 14:54 ACST

Resolved
This incident has been resolved.
Posted Feb 15, 2021 - 13:26 ACDT
Monitoring
We have released a fix for an issue where some videos uploaded to CareApp using CareApp Mobile on Android are not appearing correctly in the feed. The updated app (2.16.1) can be downloaded from the Google Play Store.

We will be fixing the issues for videos that have already been uploaded - there is no need to recreate the messages.
Posted Feb 15, 2021 - 13:12 ACDT
Identified
We are investigating an issue where some videos added from Android phones are not appearing correctly in the feed.
Posted Feb 15, 2021 - 10:00 ACDT
This incident affected: CareApp Mobile.